Konfigurasi Vlan Pada Switch

Konfigurasi Vlan Pada Switch - Virtual LAN atau biasa disebut dengan Vlan merupakan sebuah virtual ethernet layer 2 yang mampu melakukan management segment pada sebuah port ethernet. Dengan vlan kita dapat membuat banyak workstation tanpa memerlukan banyak tambahan perangkat fisik. Vlan juga membuat pengaturan jaringan antar divisi atau segment dapat lebih flexible.

Baca Juga :
Recovery password cisco 2600 series
Setting password console dan telnet router cisco
Konfigurasi NAT pada router cisco 

Untuk lebih jelasnya disini saya sudah memiliki sebuah contoh topologi vlan sederhana.


Pada gambar diatas kita umpamakan terdapat 2 divisi yaitu noc dan marketing. Ruang noc berada di lantai 1, sedangkan ruang marketing ada pada lantai 2. Untuk perangkat router dan switchnya ada di lantai 3 ruang server. 

Nah, sebelum kita mulai pada contoh diatas untuk port trunk sendiri dimiliki switch pada port f1/0. Trunk maksudnya itu adalah port yang mendukung banyaknya lalu lintas dari vlan id serta mendistribusikan traffic ke vlan access. Oleh karena itu trunk wajib ada dalam sebuah konfigurasi vlan.

Oke langsung saja pada pokok konfigurasi vlannya.

Konfigurasi R1 

== Set IP Router ==
R1#conf t
R1(config)#int f0/0
R1(config-if)#ip add 10.1.1.1 255.255.255.252
R1(config-if)#no shut

== Membuat Vlan 101 ==
R1(config)#int f0/0.101
R1(config-subif)#encapsulation dot1Q 101
R1(config-subif)#ip address 172.16.1.1 255.255.255.248
R1(config-subif)#desc Noc
R1(config-subif)#no shut
R1(config-subif)#exit

== Membuat Vlan 102 ==
R1(config)#int f0/0.102
R1(config-subif)#encapsulation dot1Q 102
R1(config-subif)#ip address 192.168.1.1 255.255.255.0
R1(config-subif)#desc Marketing
R1(config-subif)#no shut
R1(config-subif)#exit

Konfigurasi Switch

== Set ip Trunk dan Default gateway ==
Switch#conf t
Switch(config)#int vlan 1
Switch(config-if)#ip add 10.1.1.2 255.255.255.252
Switch(config-if)#no shut
Switch(config-if)#desc TRUNK
Switch(config-if)#exit
Switch(config)#ip default-gateway 10.1.1.1

== Vlan Id ==
Switch#vlan database
Switch(vlan)#vlan 101 name Noc
Switch(vlan)#vlan 102 name Marketing

== Set Vlan ==
Switch(config)#int f1/0
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

Switch#conf t
Switch(config)#int f1/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 101
Switch(config-if)#exit
Switch(config)#

Switch(config)#int f1/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 102
Switch(config-if)#exit
Switch(config)#exit
Switch#

Ping Switch ke Router 

Switch#ping 10.1.1.1 rep 50

Type escape sequence to abort.
Sending 50, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (50/50), round-trip min/avg/max = 20/32/80 ms
Switch#
Jika sudah sampai saat ini, selanjutnya tinggal konfigurasi ip address pc dari masing-masing client.

Ping PC 1 ke PC 3

PC1> ping 192.168.1.2
84 bytes from 192.168.1.2 icmp_seq=1 ttl=63 time=31.442 ms
84 bytes from 192.168.1.2 icmp_seq=2 ttl=63 time=31.509 ms
84 bytes from 192.168.1.2 icmp_seq=3 ttl=63 time=62.623 ms
84 bytes from 192.168.1.2 icmp_seq=4 ttl=63 time=20.293 ms
84 bytes from 192.168.1.2 icmp_seq=5 ttl=63 time=31.474 ms

PC1>

Demikian tutorial singkat ini mengenai Cara Konfigurasi Vlan Pada Switch. Semoga bermanfaat bagi kita semua dan selamat mencoba.

Konfigurasi Watchdog Mikrotik RB750


Konfigurasi Watchdog Mikrotik RB750 - Pada artikel singkat kali ini saya akan menjelaskan bagimana cara menggunakan system watchdog di mikrotik. System Watchdog merupakan sebuah tools mikrotik yang mengizinkan kita membuat sebuah schedule untuk melakukan reboot system jika suatu mikrotik mengalami malfunction/hang ketika sebuah ip address tidak bisa di ping.

Baca juga : 
Cara menghapus log di mikrotik
Oke langsung saja pada pembahasan kita kali ini mengenai system watchdog mikrotik RB750.
[admin@R2] > system watchdog set watch-address=10.1.1.1 no-ping-delay=3m watchdog-timer=yes auto-send-supout=yes send-smtp-server=192.168.137.1 send-email-to=noc@contoh.com
Konfigurasi watchdog diatas maksudnya watchdog akan melakukan reboot mikrotik apabila dalam waktu 3 menit alamat ip 10.1.1.1 tidak dapat di ping. Notifikasi akan dikirimkan ke email noc@contoh.com melalui ip mail server 192.168.137.1. Untuk settingan smtp itu sendiri mikrotik belum bisa menggunakan nama domain, sehingga kita harus menuliskan alamat ipnya.
[admin@R2] > system watchdog print
watch-address: 10.1.1.1
watchdog-timer: yes
no-ping-delay: 3m
automatic-supout: yes
auto-send-supout: yes
send-email-to: noc@contoh.com
send-smtp-server: 192.168.137.1
[admin@R2] >
Nah, seperti itulah kurang lebih cara melakukan konfigurasi watchdog mikrotik rb750.
Sekian tutorial singkat ini, semoga bermanfaat bagi kita semua dan selamat mencoba.!!

Konfigurasi NAT pada Cisco Router

Konfigurasi NAT pada Cisco Router - Pada artikel kali ini saya akan menjelaskan bagimana melakukan konfigurasi Nat pada cisco. NAT (Network Address Translation) merupakan sebuah protokol pada jaringan yang memungkinkan jaringan privat dapat terhubung ke internet, secara garis besar Nat itu akan membelokan traffic yang melewati router.

Baca juga:
Recovery password cisco 2600 series
Setting password console dan telnet router cisco

Karena terbatasnya alamat ip publik yang ada di internet maka banyak Internet Provider menggunakan cara ini untuk mengcover jaringan lan pada sisi client agar tetap terhubung ke internet. Biasanya ISP hanya memberikan 1 buah IP publik untuk client mereka dan dari 1 ip publik itulah nantinya jaringan Lan pada sisi client dapat terhubung ke internet.

Nah, untuk mempermudah kita belajar kali ini. Saya memiliki sebuah topologi jaringan lan seperti berikut.


Pada contoh di atas, kita asumsikan jaringan router R1 mendapatkan blok ip address dari ISP adalah 192.168.137.0/24 ( Wah, banyak banyak sekali dong? ). Interface f0/0 akan digunakan sebagai interface WAN sedangkan interface f1/0 akan digunakan sebagai interface LAN. 

Ket :
Internet:192.168.137.1/24
R1 f0/0:192.168.137.2/24
R1 f1/0:10.1.1.1/29

Konfigurasi NAT pada Cisco Router

Set ip address untuk WAN
R1#conf t
R1(config)#int f0/0
R1(config-if)#ip add 192.168.137.2 255.255.255.0
R1(config-if)#ip nat outside
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#

Set ip address untuk LAN
R1(config)#int f1/0
R1(config-if)#ip add 10.1.1.1 255.255.255.248
R1(config-if)#ip nat inside
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#

Set default gateway dan NAT
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.137.1
R1(config)#ip nat inside source list 1 int f0/0 overload

Konfigurasi pada Register Cisco

R1#show run
Building configuration...
......
interface FastEthernet0/0
ip address 192.168.137.2 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address 10.1.1.1 255.255.255.248
ip nat inside
shutdown
duplex auto
speed auto
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.137.1
no ip http server
!
access-list 1 permit 10.1.1.0 0.0.0.7
......

Test Koneksi Internet 

R1#ping google.com
Translating "google.com"...domain server (255.255.255.255) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 74.125.200.138, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/82/92 ms
R1#
Demikian tutorial singkat saya kali ini mengenai Konfigurasi NAT pada Cisco Router, semoga bermanfaat bagi kita semua.

Setting Password Console dan Telnet Router Cisco

Setting Password Console dan Telnet Router Cisco - Yak, selamat siang. Di masih waktu jam kerja ini saya akan berbagi sedikit mengenai tutorial cara setting password telnet dan console pada router cisco. Sebelumnya kita juga pernah membahas bagimana cara untuk melakukan reset password router cisco. Baca di sini:
Recovery dan Reset Password Cisco 2600
Pada artikel kali ini, masih dalam lingkup pembahasan konfigurasi dasar. 



Untuk setting password pada cisco seharusnya dilakukan pada virtual terminal (vty) dan console. Karena untuk melakukan konfigurasi pada router cisco memang dapat dilakukan menggunakan 2 cara yaitu telnet dan console. Permberian password console akan memberikan keamanan bagi mereka yang ingin melakukan konfigurasi langsung pada perangkat router dengan menggunakan kabel consol, sedangkan pemberian password ada vty akan memberikan keamanan pada router bagi mereka yang ingin melakukan konfigurasi via remote. Umumnya router cisco sendiri memiliki vty dari 0 sampai 4. Akan tetapi beberapa version lain mungkin berbeda. Dengan memberikan password router cisco maka hanya benar-benar orang yang memiliki hak akses saja yang dapat melakukan konfigurasi.

Oke, langsung saja. Pertama kita akan memberikan password default pada router cisco.
R1>enable
R1#configure terminal
R1(config)#enable secret pwd123
R1(config)#exit
Setelah anda membuat default password router cisco selanjutnya, buatlah password console. Caranya seperti berikut ini.
R1>enable
R1#configure terminal
R1(config)# line con 0
R1(config-line)# password pwd123
R1(config-line)# login
R1(config-line)# exit
Nah, sampai saat ini ada sudah melakukan setting password pada console. Selanjutnya set password pada telnet.
R1>enable
R1#configure terminal
R1(config)# line vty 0 4
R1(config-line)# password pwd123
R1(config-line)# login
R1(config-line)# exit
Ket : pwd123 adalah password yang akan kita gunakan.

Jika semua konfigurasi sudah dilakukan jangan lupa untuk menyimpannya pada register dengan menggunakan perintah "write" pada privilage mode. Anda juga dapat melihat konfigurasinya dengan mengetikan perintah "show run".

Bagaimana cukup mudah bukan? Mungkin ini saja yang dapat saya bagikan mengenai cara setting password console dan telnet pada router cisco. semoga bermanfaat bagi kita semua dan selamat mencoba..!!

Can't Mount Ntfs Drive - The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount.

Can't Mount Ntfs Drive - Beberapa hari yang lalu saya mendapatkan sebuah harddisk dari salah satu teman kerja dulu. Sebenarnya saya memang sedang membutuhkan sebuah harddisk untuk menggantikan harddisk primary saya yang sudah terkena bad sector di 11 titik. 

Baca juga :
Mengecek Performa Baca-Tulis Harddisk di Linux
Akhirnya saat ini saya menggunakan 2 buah harddisk di komputer. Yang satu saya khusukan untuk OS dan harddisk yang satunya saya khususkan untuk Data. Karena pada disk os yang saya memasang dual boot Windows 8.1 dan Ubuntu 14.04 Lts, mungkin ini adalah bug yang di bawa ubuntu jika di pasangkan dual boot dengan windows 8.1, pasalnya setelah browsing tidak sedikit juga yang mengalami masalah yang sama.

Problem: "Tidak bisa mount ntfs Data pada harddisk yang satunya"


Error mounting /dev/sdb1 at /media/rio/Data: Command-line `mount -t "ntfs" -o
"uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdb1" "/media/rio/Data"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sdb1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.
(udisks-error-quark, 0)
Seperti itulah pesan error yang di tampilkan. Permasalahan ini terjadi karena windows 8.1 setelah di matikan akan menyimpan cache disk yang di load, sehingga ubuntu tidak bisa mengaksesnya secara read-write

Untuk memperbaikinya kita dapat menggunakan "ntfsfix" pada ubuntu.
root@shineofbara:/home/rio# ntfsfix /dev/sdb1
Mounting volume... The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
FAILED
Attempting to correct errors...
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sdb1 was processed successfully.
Itu saja artikel saya mengenai mengenai cara memperbaiki "can't mount ntfs drive" . Semoga bermanfaat bagi kita semua dan selamat mencoba..!!

Baca Juga:
Install sunflower file manager twin-panel di ubuntu


Meningkatkan Pelanggan Youtube dengan Tombol Subscribe Pada Blog

Meningkatkan Pelanggan Youtube - Beberapa hari yang lalu saya pernah membahas bagaimana cara untuk membuat saluran di youtube. Nah, bagi anda yang sudah berhasil membuat channel dan menghasilkan uang di youtube, maka mendapatkan pelanggan merupakan syarat wajib yang harus anda lakukan agar viewer anda semakin bertambah.

Salah satu usaha untuk membantu mendapatkan pelanggan channel anda adalah dengan tombol subscribe yang anda pasang pada blog. Tentunya jika visitor blog anda mengetahui bahwa anda juga memiliki sebuah channel di youtube dan content yang anda sediakan adalah video berkualitas maka tidak menutup kemungkinan visitor tersebut akan berlangganan channel anda juga bukan? 

Untuk memasang tombol subscribe youtube ini pada blog caranya sangatlah mudah, karena anda dapat membuatnya langsung pada google developer. Silahkan anda masuk ke halaman setup berlangganan youtube dan kemudian pilih "Configure a button".



Setelah itu, anda hanya tinggal memasukan Id atau nama saluran milik anda pada "channel name or id". Bagi anda yang tidak mengetahui id saluran, anda bisa mengetahuinya di halaman Account Advanced Youtube. Untuk melihatnya anda diwajibkan login terlebih dahulu ya.

Pada menu selanjutnya anda bisa memilih "Theme" dan "Layout" yang ingin anda gunakan. Terdapat 2 buah thema yaitu "Default" dan "Dark".



Selesai menentukan layout dan thamenya, anda bisa langsung melihat previewnya di sebelah kanan menu options.

Nah, sekarang konfigurasai button subscribe anda sudah selesai. Langkah selanjutnya yaitu "copy" kode yang sudah di generate tadi dan letakan di "widget html" pada halaman "tata letak" di blogger anda. Seperti pada gambar di bawah ini.


Setelah semuanya oke, maka tombol subscribe youtube akan langsung tampil pada blog anda.

Gimana mudah sekali bukan membuatnya?

Mungkin itu saja artikel saya kali ini.  Semoga dengan kita menambahakan tombol subscribe youtube pada blog pelanggan kita semakin bertambah ya.

Demikian tutorial singkat ini mengenai cara meningkatkan pelanggan youtube dengan tombol subscribe pada blog


Selamat mencoba..!!

Cara Download Video di Youtube


Cara Download Video di Youtube - Saat ini siapa yang tidak kenal dengan salah satu situs penyedia video sharing terbesar youtube.com?. Hampir seluruh pengguna internet di dunia pasti penah mengakses situs ini. Mungkin saat anda baru pertama kali membuka situs ini dan berniat untuk mendownloadnya anda akan merasa bingung, karena seperti yang telah kita ketahui bahwa youtube tidak menyediakan tombol untuk mendownload file video yang di unggah ke situsnya.

Nah, Pada kesempatan kali ini saya akan menjelaskan bagaimana cara download video youtube di ubuntu. Untuk pengguna linux sendiri sudah tersedia sebuah script yang di bagun menggunakan bahasa pemrograman python yaitu Youtube-dl. Selain cara ini sangat ampuh, tools ini juga sangat cepat dan ringan karena berbasis dengan command-line. Youtube-dl juga dapat kita gunakan pada situs penyedia video sharing lainnya seperti Dailymotion Google Video, Photobucket, Metacafe dan lain-lain.

Oke, langsung saja pada pokok pembahasan kita kali ini. Untuk menginstall dan menggunakan tools ini sangatlah mudah anda hanya perlu mengikuti langkah-langkah di bawah ini.

Install Youtube-dl di Ubuntu
root@shineofbara:/home/rio# add-apt-repository ppa:nilarimogard/webupd8
root@shineofbara:/home/rio# apt-get update
root@shineofbara:/home/rio# apt-get install youtube-dl
Bagi anda yang sebelumnya sudah menginstall youtube-dl dan ingin memperbaharui tools tersebut bisa menggunakan perintah berikut.
root@shineofbara:/home/rio# youtube-dl -U
Cara menggunakan Youtube-dl

Sebelum menggunakan tools ini, langkah yang harus anda lakukan adalah menyiapkan url video yang ingin anda download dan ketikan perintah berikut pada terminal.
root@shineofbara:/home/rio# youtube-dl -F https://www.youtube.com/watch?v=ndfW9udn7No
Text yang berwarna merah adalah url video yang ingin anda download. Sedangkan "-F" merupakan option untuk melihat format yang tersedia untuk video tersebut.
[youtube] Setting language
[youtube] Confirming age
[youtube] ndfW9udn7No: Downloading webpage
[youtube] ndfW9udn7No: Downloading video info webpage
[youtube] ndfW9udn7No: Extracting video information
[youtube] ndfW9udn7No: Downloading DASH manifest
[info] Available formats for ndfW9udn7No:
format code extension resolution note
17 3gp 176x144
36 3gp 320x240
5 flv 400x240
43 webm 640x360
18 mp4 640x360 (best)
root@shineofbara:/home/rio#
Misal jika kita ingin mendownload video dengan format mp4 640x360 maka perintahnya seperti di bawah ini.
root@shineofbara:/home/rio# youtube-dl -f 18 https://www.youtube.com/watch?v=ndfW9udn7No
Angka 18 diatas adalah Id dari format video yang ingin kita dowload.
[youtube] Setting language
[youtube] Confirming age
[youtube] ndfW9udn7No: Downloading webpage
[youtube] ndfW9udn7No: Downloading video info webpage
[youtube] ndfW9udn7No: Extracting video information
[youtube] ndfW9udn7No: Downloading DASH manifest
[download] Destination: Peterpan - Menghapus Jejakmu-ndfW9udn7No.mp4
[download] 4.5% of 8.19MiB at 114.68KiB/s ETA 01:09
Tunggu hingga download videonya selesai.

Demikian tutorial saya kali ini mengenai Cara Download Video Youtube di Ubuntu. Semoga bermanfaat bagi kita semua dan selamat mencoba.!!

Recovery Password Cisco 2600 Series


Reset Password Cisco 2600 Series - Pada kesempatan kali ini saya akan menjelaskan bagimana cara untuk melakukan reset password cisco. Seperti yang sudah saya sebutkan diatas, bahwa perangkat yang saya gunakan adalah Cisco 2600 Series. Oke, langsung saja pada pokok pembahasan kita mengenai reset password cisco 2600 series.

Dibawah ini merupakan tampilan login router cisco yang akan kita reset karena tidak bisa masuk ke dalam user exec mode.
Router con0 is now available
Press RETURN to get started.
User Access Verification

Password:
Untuk melakukan recovery password atau "Break Password", langkah pertama yang harus anda lakukan adalah masuk pada mode bootrom prompt dengan cara reboot perangkat cisco anda kemudian pada saat proses booting ios tekan tombol Ctrl+f. Berikut ini adalah tampilan bootrom prompt cisco setelah anda masuk.
System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)
Copyright (c) 2003 by cisco Systems, Inc.
C2600 platform with 262144 Kbytes of main memory

rommon 1 >
Selanjutnya ubah konfigurasi register agar kita dapat mengakses content dari NVRAM.
rommon 1 >confreg 0x2142
rommon 2 >reset
Setelah perintah "reset" dijalankan, router akan melakukan booting kembali untuk melakukan reload config register yang telah kita ubah. Pada layar tampilan initial configuraion dialog tekan tombol "no" untuk masuk kedalam user exec modes. Kemudian ketikan "enable" agar masuk pada privileged exec modes. Pada privileged mode, anda bisa melakukan backup konfigurasi start up dengan perintah "copy run start". Selanjutnya set password baru anda dan ketikan perintah "copy start run" untuk menyimpan konfigurasi ke NVRAM.
--- System Configuration Dialog ---
Would you like to enter the initial configuration dialog? [yes/no]: n
Press RETURN to get started!

Router>enable
Router#copy start run
Destination filename [running-config]?
506 bytes copied in 3.868 secs (168 bytes/sec)
Router#configure terminal
Router(config)#enable secret NEWENABLEPASSWORD
Router(config)#line con 0
Router(config-if)#password NEWPASSWORD
Router(config-if)#end
Router#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
Router#
Perintah diatas adalah cara recovery password cisco router. Lalu, bagaimana jika anda ingin menghapus password router cisco berserta konfigurasi start up NVRAM? caranya sangatlah mudah, anda hanya perlu mengetikan "write erase" pada privileged mode.
--- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: n
Press RETURN to get started!

Router>enable
Router#write erase
Erasing the nvram filesystem will remove all files! Continue? [confirm]
[OK]
Erase of nvram: complete
Router#
Langkah terakhir adalah mengembalikan konfigurasi register seperti semula yaitu 0x2102.
Router#configure terminal
Router(config)#config-register 0x2102
Router(config)#end
Selanjutnya reboot router cisco 2600 dengan mengetikan perintah "reload" pada previleged mode.

Demikian tutorial ini mengenai cara recovery password cisco 2600 series. Semoga bermanfaat bagi kita semua dan selamat mencoba..!!

Install Sunflower File Manager Ubuntu 14.04

Install Sunflower File Manager Ubuntu 14.04 - Tulisan saya kali ini akan membahas mengenai salah satu file manager terbaik yang pernah ada. Jika pengguna Gnome/Unity file managernya di kenal dengan Nautilus dan KDE dengan Dolphin, maka saya akan memperkenalkan salah satu file manager yang anda dapat gunakan sebagai alternatif. 

Sunflower adalah sebuah file manager twin-panel yang di buat dengan menggunakan bahasa pemrograman python. Yang membaut saya sangat jatuh hati dengan file manager ini yaitu terdapat tab interface yang dapat kita gunakan sebagai quick access terminal. 

Nah, bagi teman-teman yang ingin mencoba untuk menginstallnya bisa mengikuti langkah di bawah ini.
root@shineofbara:/home/rio# add-apt-repository ppa:atareao/sunflower
root@shineofbara:/home/rio# apt-get update
root@shineofbara:/home/rio# apt-get install sunflower python-gnome2 python-mutagen python-vte
Berikut ini adalah tampilan dari sunflower.


Bagaimana, keren bukan? Kalau begitu demikian tutorial singkat saya kali ini mengenai install sunflower file manager ubuntu 14.04, semoga bermanfaat bagi kita semua dan selamat mencoba.!!

Mengecek Performa Baca-Tulis Harddisk di Linux


Mengecek Performa Baca-Tulis Harddisk di Linux - Beberapa hari yang lalu, saya mendapatkan sebuah harddisk 160 GB dari seorang teman yang sudah tidak terpakai. Hal ini bermula dari komputer saya yang semakin lambat karena bad sactor pada harddisk semakin parah. Akhirnya saya memberanikan diri untuk memformat habis harddisk baru tersebut dan menjadikan harddisk tersebut sebagai harddisk primary dual boot OS Windows dan Ubuntu dengan kapasitas masing-masing 80 GB. Setelah dilakukan pengecekan menggunakan tools harddisk, hasilnya pun memang masih cukup bagus dan tidak ada bad sactor yang serius. Walaupun demikian saya masih belum cukup puas dengan dengan hasil tersebut menginat harddisk yang saya dapatkan ini adalah harddisk model lama. Jadi saya rasa perlu dilakukan juga pengecekan pada kecepatan baca tulis pada harddisk tersebut.

Nah, untuk melakukan pengecekan performa dan kecepatan baca tulis di linux sangatlah mudah. Anda hanya perlu menjalankan perintah di bawah ini.

Kecepatan Menulis Harddisk

root@shineofbara:/home/rio# dd if=/dev/zero of=testfile bs=1M count=1024
Perintah di atas digunakan untuk melakukan copy data kosong ke testfile sebesar 1GB. Setelah itu akan ada hasil seperti di bawah ini.
root@shineofbara:/home/rio# dd if=/dev/zero of=testfile bs=1M count=1024
1024+0 records in
1024+0 records out
1073741824 bytes (1,1 GB) copied, 15,9512 s, 67,3 MB/s
Terlihat bahwa dari hasil diatas kecepatan menulis sebesar 1Gb, menghabiskan waktu 15,9512 detik atau sekitar 7-8 menit dengan kecepatan 67,3 MB/s.

Selain dengan menggunakan cara di atas, anda juga bisa menggunakan sebuah tool hdparm untuk melakukan pengecekan performa baca pada harddisk.

Kecepatan Membaca Harddisk

Pada kasus ini penulis menggunakan sebuah system operasi Ubuntu 14.04 Lts yang sudah terinstall langsung package hdparm. Cara penggunaannya pun sangat mudah, anda hanya perlu mengetikan perintah berikut pada terminal anda.
root@shineofbara:/home/rio# hdparm -t /dev/sda

/dev/sda:
Timing buffered disk reads: 212 MB in  3.00 seconds =  70.58 MB/sec
Pada pengecekan di atas menunjukan bahwa harddisk mampu membaca 212MB file, membutuhkan waktu 3 detik dengan kecepatan 70.58Mb/s.

Berdasarkan dari beberapa hasil pengecekan, saya menyimpulkan bahwa harddisk 160GB yang saya peroleh tersebut itu cukup bagus.

Demikian tutorial singkat ini mengenai Cara Mengecek Performa Baca-Tulis Harddisk di Linux. Semoga tutorial ini dapat bermanfaat bagi kita semua dan selamat mencoba..!!

Youtube

Bisnis Online