Konfigurasi Native VLAN Trunking antar Switch pada Implementasi MMR Data Center


Konfigurasi Native VLAN Trunking antar Switch - Hallo sobat oprekers, kali ini saya akan menjelaskan bagimana konfigurasi native vlan antar switch. Nah, kalau sobat belum tau sebetulnya native vlan ini merupakan salah satu bentuk implementasi yang di terapkan pada Meet Me Room (MMR) data center.  Fungsinya, agar switch antar isp dapat saling interkoneksi.   

Baca Juga :

Implementasi VLAN dalam Aspek Bisnis?

Bicara soal isp pastinya tidak terlepas dari aspek bisnis, dengan adanya interkoneksi pada mmr banyak perusahan isp yang dengan Pede nya mencari client di luar cover link mereka. Dan sudah seharunya jangkauan suatu link isp merupakan peran penting untuk menunjang kesuksesan suatu perusahaan.

Sebagai contoh ISP A hanya dapat mengcover link di area Jakarta saja, sewaktu-waktu salah satu client besar mereka memiliki cabang yang berada di Surabaya yang sudah jelas-jelas link mereka tidak mengcovernya. Disinilah peran dari mmr, isp A dapat saling interkoneksi dengan isp di surabaya dengan mempertemukan link (cable) antar switch mereka di data center.

Nah, salah satu bentuk layanannya saat ini adalah Clear Channel dengan meneruskan vlan dari suatu site ke site yang lain.

Oke Sobat, untuk lebih jelasnya mari kita simulasikan saja.


Pada topologi di atas merupakan bentuk pembelajaran kali ini, saya juga masih mengambil contoh kasus sebelumnya yaitu meneruskan vlan dari jakarta ke surabaya melalui isp B. Sedangkan client isp A di surabaya terhubung pada swicth distribusi dari isp B.

Konfigurasi Router ISP-A

Set IP untuk Router dan alokasikan vlan yang akan di teruskan ke surabaya. Disini saya menggunakan vlan 100 untuk client di surabaya.
isp-a>en
isp-a#conf t
isp-a(config)#int fa0/0
isp-a(config-if)#ip add 10.1.1.1 255.255.255.252
isp-a(config-if)#no shut
isp-a(config-if)#exit
isp-a(config)#int fa0/0.100
isp-a(config-subif)#en dot1Q 100
isp-a(config-subif)#ip add 10.7.1.1 255.255.255.252
isp-a(config-subif)#no shut
isp-a(config-subif)#(ctrl-z)
Berikut hasil konfigurasinya.


Konfigurasi Switch ISP A 

Buat masing-masing vlan yang sudah di tentukan yaitu vlan 10 (native), vlan 7 dan vlan 100 untuk client.
sw-ispA>en
sw-ispA#conf t
sw-ispA#vlan database
sw-ispA(vlan)#vlan 10 name trunk
sw-ispA(vlan)#vlan 7 name ptp-ispB
sw-ispA(vlan)#vlan 100 name cl-sby
sw-ispA(vlan)#exit
Set ip untuk trunk agar switch bisa di remote.
sw-ispA#conf t
sw-ispA(config)#int vlan 10
sw-ispA(config-if)#ip add 10.1.1.2 255.255.255.252
sw-ispA(config-if)#no shut
sw-ispA(config-if)#(ctrl-z)
Set f0/1 sebagai native vlan 10, dan izinkan vlan 10,7 dan 100.
sw-ispA#conf t
sw-ispA(config)#int fa0/1
sw-ispA(config-if)#switchport mode trunk
sw-ispA(config-if)#switchport trunk native vlan 10
sw-ispA(config-if)#switchport trunk allowed vlan 10,7,100
sw-ispA(config-if)#exit
sw-ispA(config)#
Set f1/1 sebagai native vlan 7 dan izinkan vlan 100 untuk lewat.
sw-ispA(config)#int fa 1/1
sw-ispA(config-if)#switchport mode trunk
sw-ispA(config-if)#switchport trunk native vlan 7
sw-ispA(config-if)#switchport trunk allowed vlan 7,100
sw-ispA(config-if)#(ctrl-z)
 Berikut ini hasil konfigurasinya.


Sampai disini konfigurasi untuk ISP A sudah selesai, selanjutnya konfigurasi pada ISP B.

Konfigurasi Router ISP-B

Set ip untuk router ISP-B, karena disini pada router isp memiliki 2 buah switch maka kita menggunakan prefix /29 agar masing-masing switch bisa di remote.
isp-b>en
isp-b#conf t
isp-b(config)#int fa0/0
isp-b(config-if)#ip add 20.1.1.1 255.255.255.248
isp-b(config-if)#no shut
isp-b(config-if)#(ctrl-z)

Konfigurasi Switch ISP-B 

Buat masing-masing vlan yang sudah di tentukan, vlan 20 (native) dan sedangkan vlan 7 (native) untuk link ke switch isp A.
sw-ispB>en
sw-ispB#vlan database
sw-ispB(vlan)#vlan 20 name trunk
sw-ispB(vlan)#vlan 7 name ptp-ispA
sw-ispB(vlan)#vlan 100 name client-ispA
sw-ispB(vlan)#exit
Selanjutnya set f0/0 sebagai native trunk dan berikan ip untuk vlan 20 agar bisa swtich bisa di akses dari router.
sw-ispB#conf t
sw-ispB(config)#int fa0/1
sw-ispB(config-if)#switchport mode trunk
sw-ispB(config-if)#switchport trunk native vlan 20
sw-ispB(config-if)#switchport trunk allow vlan 20
sw-ispB(config-if)#exit
sw-ispB(config)#int vlan 20
sw-ispB(config-if)#ip add 20.1.1.2 255.255.255.248
sw-ispB(config-if)#no shut
sw-ispB(config-if)#exit
Langkah selanjutnya set interface fa1/1 sebagai native vlan7 dan buat rule agar vlan 100 dari isp A dapat lewat.
sw-ispB(config)#int fa1/1
sw-ispB(config-if)#switchport mode trunk
sw-ispB(config-if)#switchport trunk native vlan 7
sw-ispB(config-if)#switchport trunk allowed vlan 7,100
sw-ispB(config-if)#(ctrl-z)
Berikut hasil konfigurasinya sobat.


Nah, sampai disini vlan 100 sudah diteruskan sampai ke swtich isp B (perhatikan pada vlan allowed). Langkah selanjutnya yaitu meneruskan vlan 100 ke switch distribusi.

Pada fa2/1, lakukan konfigurasi agar vlan 100 bisa di teruskan ke switch distribusi. Jangan lupa juga buat untuk mengizinkan native vlan 20 agar router isp B bisa mengakses sampai ke switch distribusi.
sw-ispB#conf t
sw-ispB(config)#int fa2/1
sw-ispB(config-if)#switchport mode trunk
sw-ispB(config-if)#switchport trunk native vlan 20
sw-ispB(config-if)#switchport trunk allowed vlan 20,100
sw-ispB(config-if)#(ctrl-z)
Berikut ini adalah hasilnya.

Perhatikan pada fa2/1, artinya vlan 100 sudah di teruskan switch distribusi.
Sekarang sobat hanya tinggal mengkonfigurasi swtich dirstribusi agar menerima vlan dari switch isp B.

Konfigurasi Switch Distribusi ISP B

Nah, sobat sampai disini lah yang paling seru dimana vlan 100 yang di buat dari router isp A - jakarta bisa diteruskan sampai ke client yang di surabaya.


Langkah pertama pada swtich distribusi, buat masing-masing vlan yang sudah di tentukan. Vlan 20 untuk (native) dan vlan 100 untuk vlan access ke client.
sw-dist>en
sw-dist#vlan database
sw-dist(vlan)#vlan 20 name trunk
sw-dist(vlan)#vlan 100 name client-ispA
sw-dist(vlan)#exit
Setelah itu set interface f0/1 sebagai trunk ke switch isp-B yang ada di MMR.
Buat juga ip agar switch distribusi dapat di remote dari router isp B.
sw-dist#conf t
sw-dist(config)#int fa0/1
sw-dist(config-if)#switchport mode trunk
sw-dist(config-if)#switchport trunk native vlan 20
sw-dist(config-if)#switchport trunk allowed vlan 20,100
sw-dist(config-if)#exit
sw-dist#conf t
sw-dist(config)#int vlan 20
w-dist(config-if)#ip add 20.1.1.3 255.255.255.248
sw-dist(config-if)#no shut
Sekaran set interface f1/1 sebagai vlan access ke vlan 100.
sw-dist(config)#int fa1/1
sw-dist(config-if)#switchport mode access
sw-dist(config-if)#switchport access vlan 100
sw-dist(config-if)#(ctrl-z)
Berikut ini adalah hasil konfigurasinya, dan lihat sekarang vlan 100 sudah di teruskan ke client.




Sekarang coba set ip pc nya ke 10.7.1.2/30 dan lakukan ping ke gateway yang ada di router isp A jakarta.


Nah, gimana sobat? asik bukan? :D
Kurang lebihnya seperti itu sobat cara meneruskan vlan dari site ke site yang di implementasikan di Meet me room. Asalkan terinterkoneksi dengan MMR tercover lah pokoknya..hehe

Perlu diketahui juga sobat, walaupun client isp A berada di bawah jaringan ISP B tetap saja client ISP A tidak bisa mencampuri network yang ada di ISP B karena sudah beda vlan. Biasanya untuk mengimplementasikan cara ini di perlukan perjanjian kedua belah pihak mengenai vlan yang di gunakan, jangan sampai nanti vlannya bentrok. 

Download konfigurasinya disini.

Demikian tutorial kali ini mengenai konfigurasi native vlan trunking antar switch pada implementasi MMR data center. Semoga bermanfaat dan selamat mencoba..!!


EmoticonEmoticon